Install PHP 5.6 di Linux Ubuntu 16.04 (LTS)

Install PHP5.6 di Ubuntu 16.04
Ubuntu 16.04 (LTS) baik Server maupun Desktop secara defaultnya telah membawa PHP 7 dalam paket instalasinya, sehingga ketika kita menginstall LAMP, maka versi PHP yang terpasang secara otomatis adalah PHP Versi 7. Nah namun terkadang kita membutuhkan PHP versi 5.6 karena beberapa hal diantaranya adalah:
  1. Untuk coba-coba aja
  2. Karena kita memiliki aplikasi yang dibangun dan berjalan di php 5.6, dan belum kompatibel dengan php 7.
  3. Alasan Lainnya... :D
Dengan alasan itulah pada postingan kali ini saya akan berbagi bagaimana melalukan instalasi php 5.6 di Ubuntu 16.04. Berikut adalah langkah-langkah untuk instalasinya:

Lakukan update repository dan tambahkan repository baru dengan perintah berikut:
$ sudo apt-get update
$ sudo apt-get install -y software-properties-common
$ sudo add-apt-repository ppa:ondrej/php

Perbarui cache repository menggunakan perintah berikut ini:
$ sudo apt-get update

Install PHP 5.6 dengan perintah:
$ sudo apt-get install -y php5.6

Cek Versi PHP dengan perintah:
$ php -v

Hasilnnya :
PHP 7.0.4-7ubuntu2 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies


Jika masih terlihat versi 7, maka kita dapat memilih versi php yang secara default akan digunakan dengan perintah:
$ sudo update-alternatives --config php

There are 2 choices for the alternative php (providing /usr/bin/php).

  Selection    Path             Priority   Status
------------------------------------------------------------
* 0            /usr/bin/php7.0   70        auto mode
  1            /usr/bin/php5.6   56        manual mode
  2            /usr/bin/php7.0   70        manual mode

Press <enter> to keep the current choice[*], or type selection number: 1
update-alternatives: using /usr/bin/php5.6 to provide /usr/bin/php (php) in manual mode

Pilih nomor 1, untuk mengaktifkan php 5.6, dan cek kembali versi php yang berjalan dengan perintah php -v

PHP 5.6.34-1+ubuntu16.04.1+deb.sury.org+1 (cli) 
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

Oke.., seperti itu kira-kira yang dapat saya bagikan kali ini, mudah-mudahan bermanfaat.

Subscribe to receive free email updates:

0 Komentar pada "Install PHP 5.6 di Linux Ubuntu 16.04 (LTS)"

Posting Komentar